Wellsville 11-29-14

Post your Vehicle and Trail pictures here

Moderator: phpBB2 - Administrators

Stock Wheeler
User avatar
Posts: 31
Joined: Sat Dec 24, 2005 3:39 pm
Location: Lancaster, OH

Wellsville 11-29-14

Postby OffRoadOhio » Thu Dec 04, 2014 6:56 pm

Few videos.
http://youtu.be/ijgvRG9K3t4?list=UUtAUu ... 1oHXtxEZkQ
Lucky Chucky ( little rock garden)

http://youtu.be/GqWuYkM2X3g?list=UUtAUu ... 1oHXtxEZkQ
Sturgis

http://youtu.be/Wq_hIzDhRw8?list=UUtAUu ... 1oHXtxEZkQ
Chuck breaking his junk after I am smart and pull out (this guy had no front locker, has a jeep thats 4.3 powered with yota axles and NO front locker... took out rear shaft

http://youtu.be/m7-OSxqbG4s?list=UUtAUu ... 1oHXtxEZkQ
Cj in raincoat damaging his fiberglass tub. What a puss puss!!!

Photos:
http://www.offroadohio.com/gallery/albu ... lbum_id=56

We like to lay em over..
Image

Image

Image

Image

Master Wheeler
User avatar
Posts: 720
Joined: Wed Sep 28, 2005 9:05 am
Location: Cedar Grove, IN

Re: Wellsville 11-29-14

Postby kesterkamp » Thu Dec 04, 2014 7:03 pm

nice... never been to wellsville
15 Buggy
88 Jeep Wrangler DAD'S
95 Jeep Cherokee DEAD
00 Ford F-250
03 Honda Accord

Stock Wheeler
User avatar
Posts: 31
Joined: Sat Dec 24, 2005 3:39 pm
Location: Lancaster, OH

Re: Wellsville 11-29-14

Postby OffRoadOhio » Thu Dec 04, 2014 7:38 pm

Would be a pretty long haul for you. Youd be better off hitting IVY Branch WV.

Flexy Wheeler
Posts: 256
Joined: Fri Jan 09, 2004 10:25 pm

Re: Wellsville 11-29-14

Postby GreenJPTJ » Thu Dec 04, 2014 9:05 pm

We went to Wellsville a few years ago as a club. What a fiasco that was.

You know the weekend is going to be rough when the tow rigs start breaking down on the way there.

Stock Wheeler
User avatar
Posts: 31
Joined: Sat Dec 24, 2005 3:39 pm
Location: Lancaster, OH

Re: Wellsville 11-29-14

Postby OffRoadOhio » Fri Dec 05, 2014 7:40 am

We had the same issue on this trip. WE had 4 including me heading from Lancaster, and we met 3 more in Cambridge. When we got to Zanesville on the way to cambridge we lost a half ton chevy tow rigs tranny. Luckily I am originally from the area, and we have two offroad parks not far from there so we made some calls and got his truck and trailer back to Lancaster so so we could continue on.

From there the hold ups kept coming. 15 minutes in my toyota had a charging gremlin and shut down. wiggles and unplugged and replugged wires and jump started it then it was fine. made it through lucky chucky and broke a cherokee radiator. went up sturgis and then the video of the jeep breaking a rear shaft happened on the next trail. Then once we got into raincoat ( the holler to some) it was just stop wait winch for 4 hours.

Return to Pictures from the Trail

Who is online

Users browsing this forum: No registered users and 2 guests