ford 7.3 ignition problem

Discuss Upgrades and Fixes

Moderator: phpBB2 - Administrators

Master Wheeler
User avatar
Posts: 780
Joined: Wed Apr 14, 2004 1:59 pm
Location: In front of the computer

ford 7.3 ignition problem

Postby eddie platt » Wed Nov 10, 2010 2:13 pm

so this week i traded my 800 dollar grand cherokee that i have been daily driving for the past few months for a 94 ford diesel. its a 7.3 crew cab 2wd with a 5 speed! i love it.

anyway, the problem i have been having is trying to start it. i turn the ignition on, let the glow plugs cycle for about 10 seconds, when they are done i turn the key and nothing.... make sure the clutch is pushed in all the way, turn it off, back on, the gp's cycle and still nothing. like the batteries are dead. i repeat this a few times then finally the thing turns over and fires right up.

anyone have any experience with these?
Attachments
333.JPG
333.JPG (205.38 KiB) Viewed 5050 times

Flexy Wheeler
Posts: 187
Joined: Sun Jan 13, 2008 12:54 pm
Location: mainville,oh

Postby dbach » Thu Dec 02, 2010 6:49 pm

nice new ride or should i say tow vehicle. sorry i cant fix your problem with it . do i see a plan here or what ? tow vehicle ,next a trailer ,do i see your grand turning to a buggy ?

Master Wheeler
User avatar
Posts: 780
Joined: Wed Apr 14, 2004 1:59 pm
Location: In front of the computer

Postby eddie platt » Fri Dec 03, 2010 9:45 am

no, no buggy here. i love my big full bodied rig too much. i might get a trailer for longer trips, but still plan on driving it for the most part.

plans are just basic maintenance stuff, make the truck not so ugly, maybe paint it if i have time. new tires, etc.. fix the leaky rear tank lines.
its an awesome truck and im loving driving the 5 speed. its got alot of power. i had the rear sitting on the overload springs last week with a big load of concrete pavers and some big pieces of wood - and it did great.

Return to Tech Info

Who is online

Users browsing this forum: No registered users and 2 guests